Support Tool
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted 5 days ago. Dec 06, 2018 - 20:59 GMT
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted 5 days ago. Dec 06, 2018 - 17:34 GMT
This incident affected: Customer Service (Support Tool).